port number

20 October 2008, 13:35
Hi Hugo...

I'm extremely happy that problem related to URL rewriting is solved!!!!!:D
Thanks a ton for your guidance.

Coming to port number change, the problem still exists...
When I change the port number to say 5656, then http://localhost:5656 is launching the index I don't think it's Hiawatha's loophole this time...

I'm not sure out if its code fault in my application either!!!!Will get back to you on this...
Hugo Leisink
20 October 2008, 13:54
I've taken a look at your previous messages and found this remark:
a.conf ---- This holds the 3 parameters HttpdHost(IP address of the machine),
HttpdPort(as in server conf file) and Daemon PortNumber (as in daemon.conf)

Isn't it weird that the a*.exe applications need to know the HTTP port?? A CGI application has nothing to do with the port number of the webserver. So, my guess is you are dealing with a badly written application....
20 October 2008, 15:15
May be weird ; but this is an optional parameter which can be omitted in case the server is run on default port (80).
My application is supposed to be compatible with any port on server and in case the SERVER_PORT CGI environment variable is not set properly then we will have option of reading the server port number from a.conf as well...

Hugo Leisink
20 October 2008, 15:28
Hiawatha sets the SERVER_PORT correctly, so it shouldn't be necessary to set the option then. I've been thinking about it. I guess the application uses the port number to generate links. Can you verify the source code of the webpages (the HTML source) and see if the port number is used correctly in the present links?
20 October 2008, 16:53
Hi Hugo,

Server Port is not the problem. Have a look on scenarios below:
I have looked into the code. We are using value from HTTP HOST environment variable.
The code is quite messy ..let me not get into explaining it to you ...
Portnumber : other than default(80)
HTTP HOST: <IP Address:Port Number>
Portnumber : default (80)
HTTP HOST: <IP Address>

Portnumber : default / other than default(80)
HTTP HOST: <IP Address>
20 October 2008, 16:55
Portnumber : other than default(80)
HTTP HOST: <IP Address:Port Number>

Is there any way we can set the HTTP HOST env variable in Hiawatha, in same format?
20 October 2008, 16:56
what is this???why is the smiley getting inserted??
Portnumber : other than default(80)
HTTP HOST: <IP Address : Port Number>
20 October 2008, 16:59
I can modify the code at my end to form host name as "server_name:server_port" values...but as this is open source web server and if code change at your end is minimal, I can avoid changing mine....:):)

waiting for your reply...
Hugo Leisink
20 October 2008, 17:35
It looks like Apache got the HTTP_HOST wrong. It should not contain the port number. The programmer of your CGI programs made it depend on the incorrect HTTP_HOST content. I'm not going to change Hiawatha because Apache messed things up, sorry. So, I guess you have to fix your program.

(fixed the smiley issue in this forum)
(can I please ask you to place your messages in one post when possible?)
22 October 2008, 15:13
Test Message
22 October 2008, 15:32
Thanks for adding to my knowledge that HTTP_HOST should not contain port number. I have modified code at my end. The problem is solved now.

I did not understand this particular sentence that you wrote in the last message of topic: port number (i.e.) ?can I please ask you to place your messages in one post when possible?? Please check my new query/message at ?URL Rewrite Rules? topic.
22 October 2008, 16:23
I?m not able to post any messages to your website from yesterday. It shows some ?_gat undefined? JavaScript error and if I still go ahead and post something it shows ?Message seen as spam? page... Do you by chance know anything about it??
Hugo Leisink
22 October 2008, 16:47
_gat is something from a Google Analytics scripts which seems to give problems in your browser. I will take a loot at it.

The 'Message seen as spam' is because my forum had some problems with your post. Please, send your post to hugo at leisink dot net so I can see what is wrong.
23 October 2008, 11:52
Were you able to find what the ?_gat undefined? problem is???

I?m not even able to download any file from ?Download? page in the forum, may be because of this error only!!!!

I need ?Source Tar Ball? and ?Windows Download Package? ASAP? What do you suggest me to do till this problem is resolved??
Hugo Leisink
23 October 2008, 12:03
The _gat problems is because of some Google Analytics scripts inside the pages. I've disabled them for now.

I've fixed the error in the download section. Please try again.
23 October 2008, 15:21
I could download the files. Thank you?

But the problem to post messages still persists.

<These messages from yesterday are being posted by my don?t get confused>
This topic has been closed.