Hiawatha and owncloud? Anybody got it running?

24 October 2012, 14:20

Hiawatha version: 8.5
Operating System: Debian Squeeze 64bit

Hi there,
i just discoverd Hiawatha a few day ago. Never had a Webserver which was so simple to use, also in terms of configuring SSL.
No i tried to use it with Owncloud 4.0.8 but that seems quite a problem. In the mean time i have managed to upload and download files to it, but none of the other funktions are working. But sharing, enabling/disabling apps, using the calendar or Contacts nothing is working. Always get failures like "Token expired" etc.
I think there must be some kind of trick for that.

So if anybody has hiawatha working with a recent version of Owncloud, please share your knowledge.
Hugo Leisink
24 October 2012, 14:33
I got it working with 3.x. I'll try version 4 soon and let you know. Of course, OwnCloud has been tested with Apache only, but I'll see what I can do.
24 October 2012, 17:42
Sounds good.
I used some of the Info i found here
What i found is that MaxRequestSize is needed in order to upload files over the WebIf. I used FastCGI because it was so easy to setup in Hiawatha.
I block the data directory via URLToolkit, which works really good.

What you can not apply from this HowTo are the settings in the php.ini, they will break Owncloud just like the hint to modify line 93 in the Response.php.
24 October 2012, 18:08
Btw. i also tried if this Token failures only occour if i use SSL, but it makes noch differenc if i use SSL or not. The failure persists.
Hugo Leisink
24 October 2012, 19:37
Hmm, the latest version of ownCloud is simply crap. The URL rewrite rules are really too ugly. I get xcache errors, CSS errors. Sorry, but I'm not going to support trash.
24 October 2012, 20:54
Same for the 4.0.8er Version?
Also tried the 4.5er, was totally crap, cant get even the basic functions working.
Hugo Leisink
25 October 2012, 22:10
4.0.8 is not a real solution, because that one has no future since there is a newer version.
Hugo Leisink
27 October 2012, 11:04
I've got 4.5.1 up and running. Don't use any URL rewriting. To get rid of the xcache errors, in lib/cache/xcache, replace the lines 27, 31 and 39 with 'return false'. Now it all looks oke.
This topic has been closed.