PHP files either trigger a download or 403 http error!

9 December 2012, 23:45

Hiawatha version: v8.6
Operating System: Arch Linux (x86_64) -- Kernel 3.6.9-1-ARCH

Hi, I've been trying to get Hiawatha running on my dev server but I just cannot seem to get PHP working!

To start with it would only serve PHP files as a download, then after I'd worked my way through the HOWTO pages on PHP + FCGI (i.e. php-fpm) I now just get a HTTP 403 'Forbidden' error.

I have set PHP-FPM to run as "http:http" and the files under '/srv/http/hiawatha' are all set to "<myuser>:http" with 755 permissions (i.e. '<myuser>' can "rwx" but group and global permission are "r-x").

The only other thing I've noticed that I'm not sure about is that Hiawatha _itself_ is set to run as user/group '65534' -- which (under unix / linux) is 'nobody'.

Should I change this to be user/group "http:http" too?

-- Thanks
Hugo Leisink
11 December 2012, 09:54
What do the error logfiles say?
12 December 2012, 21:38
Just posting as I had the exact same issue myself.
I'm not hosting multiple sites so I was working from the Default Website section, I solved it by adding UseFastCGI = PHP5 under the Default Website section of the hiawatha.conf file.
This topic has been closed.