Wordpress cgi timeout on install

Scott Millar
3 January 2009, 04:22
Just installed hiawatha on puppy linux box, the plan is to host 5-6 wordpress domains.

I used the following link to install
However I'm stuck at the first hurdle, getting cgi timeout when running the install.php script with wordpress.

Any ideas what's worng?
Hugo Leisink
3 January 2009, 11:26
I've tried a Wordpress installation myself and it worked fine. What I used is this:
UrlToolkit {
ToolkitID = wordpress
RequestURI exists Exit
Match .* Rewrite /index.php

VirtualHost {
Hostname =
WebsiteRoot = /path/to/wordpress
StartFile = index.php
TriggerOnCGIstatus = false
UseToolkit = wordpress

The Toolkit settings are only necessary if you plan to use permalinks. The error during installation is probably caused by the CGI Status error which is generated by Wordpress. The TriggerOnCGIstatus setting handles that problem.

Please let me know if this solves your problem.
This topic has been closed.