Django on Hiawatha?

3 March 2009, 03:49
Hi, I'm trying to run Django on Hiawatha and have been running into some problems.

I can get django to run as an fcgi process (currently on port 3033) but no matter which way I've tried configuring the httpd.conf file, Hiawatha doesn't seem to want to talk to it.

I've tried various conbfigurations, based upon examples from the Hiawatha wiki for other frameworks, none of them seem to work, Hiawatha will either run, but give me 404s when i try to navigate to pages that should be being served from django or it will refuse to start onb account of a syntax error in the http.conf file's FastCGIserver section.

I'm mostly confused about two things:

1. In the example httpd.conf file that came with Hiawatha (version 6.7 running on puppy linux) it specifies a section called UrlRewrite, that holds url rewriting rules. In every online example this section seems to be called UrlToolkit, which is it and how would i call it in the website settings if it is UrlRewrite not UrlToolkit (ie UseToolkit becomes UseRewrite??).

2. The only file i'v edited is the httpd.conf file, would i need to make changes to other files? I started django as an fcgi service on port 3033 but did not use cgi-fcgi to do so, could this be the problem?

Thanks in advance.
Hugo Leisink
5 March 2009, 02:19
I'm not really sure, but I think that Django (because of Perl) doesn't use the FastCGI protocol, but the SCGI protcol. SCGI is not supported by Hiawatha.

About your confussions:
1. Please, read this page. It will clear it up.
2. Please read question (and answer) 16 of the F.A.Q. first. What you need to find out is if you can use cgi-fcgi to run Django as a FastCGI daemon. My guess is that your solution lies somewhere in the cgi-fcgi tool.
This topic has been closed.