WordPress Multisite Subdirectory rules

1 April 2015, 12:44

A few weeks ago, Hugo kindly help me to convert my Nginx rule to Hiawatha rule to get my WordPress multisite working
UrlToolkit {
ToolkitID = multiwp
Call scannerblocker
Match ^/index\.php$ Return
Match ^/([_0-9a-zA-Z-]+/)?wp-admin$ Redirect /$1wp-admin/
RequestURI exists Return
Match ^/([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) Rewrite /$2
Match ^/([_0-9a-zA-Z-]+/)?(.*\.php)$ Rewrite /$2
Match .* Rewrite /index.php

with the code above, I can access my WordPress admin area for my site but when I try to add a theme for example, firefox keep giving me a The connection was reset error message.

When I look at the error log file, for that website, I have nothing in the log that can help.
Hiawatha was install from FreeBSD port and I thing this is why I don't get much details but i'm not sure.

Could anyone help me or if anyone as a worpress multisite using subdirectory, could you please share the config file

Thank you all in advance

Hiawatha version: FreeBSD10
Operating System: 9.8
Erik S
1 April 2015, 14:37
What are the permalink settings? Turn off the URLToolkit and set the permalinks to default. What happens?
Erik S
2 April 2015, 15:13
Well I tested the above and had path errors! I tried your URLToolkit and I also have not got it to work correctly. So far any time I have tried out any program that uses "pretty URLs" I have the same results. With Gallery 3 I had similar problems that with EnablePathInfo = yes that began to work suddenly. I guess some tuning of the re-writes is called for!
3 April 2015, 13:57
Hi Erik S,

Thank you for taking the time to help me here
So are you saying that in order to get my site to work, I should set
PathInfo = yes

Is the tuning fro the re-writes done on hiawatha or wordpress?

Thank you
Erik S
3 April 2015, 16:28
Hi Fred, I have not been able to get it work with multi-sites. Even with
EnablePathInfo = yes
set. I am asking Hugo to take a look at the Apache re-write rules for WordPress multi-sites to get some insight on a translation!
This topic has been closed.