about hiawatha in busybox

15 March 2007, 10:15
i have a trouble about hiawatha in busybox.
i repot the hiawatha in busybox system and linux system, the linux is worked ok. but the busybox can not support htts part. our busybox is 2.6 kernel. i found the code in ssl lib, the function of ssl_lib.c is ssl_accept() return error.
i found s->handshake_func is 0. i don't know why this s->handshake_func is 0 but in linux (2.4 kernel) is not 0. is there have troubles in configure ?
please give me some suggestions to get rid of this problem.

thank you!
Hugo Leisink
15 March 2007, 11:35
I've received some more messages about Hiawatha having problems with OpenSSL 0.9.8. I've tried Hiawatha under Ubunutu (which uses OpenSSL 0.9.8) but I haven't been able to reproduce any problem. So I'm still working on it.

For what I have seen, Busybox is just a tool. It is not a distro or something like that. Can you tell me what you are using to compile and run Hiawatha? Where did you get the OpenSSL libraries used to compile Hiawatha? What exact version are you using?
This topic has been closed.