Hiawatha 64bit on Windows?

Marius Dinu
28 September 2016, 11:43
I tried to update Hiawatha today. It didn't work. Hiawatha is now a 64-bit executable. Since when? No mention of this in the change log...
And why? Planning to use more than 3 GB of memory?
Is this the end of 32bit? I was planning an upgrade to XP64, but... so soon?
Hugo Leisink
28 September 2016, 13:27
Uh... 64bit is common for many, many years. Hiawatha is also 64bit for quite some time. If you want to have it 32bit, download and install Cygwin and compile your own version via the script extra/make_windows_package.
5 October 2016, 22:13
I have been using Hiawatha with Windows for very long and I can't recall a change from x86 to x64. What version were you using before?
x64 has been the standard for long and for optimal memory management i prefer to have all my services x64
Marius Dinu
7 October 2016, 14:12
Until now I was using Hiawatha 9.9 on Win2003 32bit.
Yesterday I tried to upgrade to Win2003 64bit. Hiawatha didn't work. Maybe you can tell me why. I'm out of ideas. I tried everything.

U:\3\Server\Hiawatha\program>hiawatha -d -c U:\3\Server\Hiawatha\config
Press Ctrl-C to shutdown the Hiawatha webserver. <-- works!

U:\3\Server\Hiawatha\program>cygrunsrv -R Hiawatha

U:\3\Server\Hiawatha\program>cygrunsrv -I Hiawatha -p U:\3\Server\Hiawatha\progr
am\Hiawatha.exe -a "-d -c U:\3\Server\Hiawatha\config" <-- install service with the exact same configuration

U:\3\Server\Hiawatha\program>net start hiawatha
The Hiawatha service is starting.
The Hiawatha service could not be started. <--- doesn't work.

A system error has occurred.

System error 1067 has occurred.

The process terminated unexpectedly.


This is the latest hiawatha with minimal changes to default conf file. (Only set INSTALL_DIR = U:\3\Server\Hiawatha was changed.)
Hugo Leisink
7 October 2016, 14:49
Did you run the cygsrv.exe commands as Administrator?

Win2003, isn't that a bit old? Have you tried a more up to date Windows version?
7 October 2016, 23:38
have you tried "-d -c /cygdrive/u/3/Server/Hiawatha/config" ?
Marius Dinu
8 October 2016, 19:26
@Hugo: I'm always an administrator. :-) I would log in to LOCAL SYSTEM if I could!
I won't use any more recent Windows versions for privacy reasons.
@kfft: Yes, including -p option. It didn't work.

Am I the only one with this problem? Did anyone succesfully run recent Hiawatha versions on Windows?
Marius Dinu
9 October 2016, 07:46
It seems there is a problem with cygrunsrv. I used Sysinternals Process Monitor to see what cygrunsrv does when it starts. It looks like hiawatha is never even launched, cygrunsrv doesn't even try to read the registry key where path to hiawatha is stored.

So I used NSSM [] to install Hiawatha as a service. And it works. Problem solved.
This topic has been closed.