Install Churchinfo CMS on hiawatha

26 March 2017, 04:10
Hi everyone am looking for help with installing Churchinfo CMS on hiawatha.
I have grave cms, fluxbb, mybb, bookings script in php running on the server
with no issues, yet I can not get Churchinfo CMS to install.
I am running on windows 10 on my laptop, using php7.1.3 with the latest hiawatha, and the most
up to date maria db.
May be someone could put together an appropriate Url toolkit for this Churchinfo CMS,

Thanks & Regards, john
I sent the below to the developer, but I know well it will take someone with knowledge of
url toolkits to make this work.
26 March 2017, 13:58
The writer of churchinfo CMS got back to me, said to change the path settings in the script,
I did all this before and again but to no avail.
The writer knows what scripts need addressed in order to install churchinfo but this information
is not forth coming, and I guess it would be unfair to expect hiawatha developer to take on
such a task, I don't know either script so no hope for me.

Regards to all, john

Joe Schmoe
27 March 2017, 18:50
Try using Default.php as your StartFile instead of index.php. I didn't see a .htaccess file which required any rewrites so it should be a pretty standard install.
28 March 2017, 12:15
Thanks Joe Shmoe

I already tried using Default.php as the start page in the virtual host,
this opened the Default.php page with no content, just blank page.
I will try using Default.php as the start page in the main host section
to see if that makes any difference.

Thanks & Regards, john
Joe Schmoe
28 March 2017, 17:14
Just installed the CMS and I did have some problems with it finding the default page so I might help to have some rewrite rules. However this configuration does work as long as you specify Default.php in the URL.

VirtualHost {
Hostname =
WebsiteRoot = /var/www/churchinfo/html
AccessLogfile = /var/www/churchinfo/logs/access.log
ErrorLogfile = /var/www/churchinfo/logs/error.log
UseFastCGI = PHP7
StartFile = Default.php

Make sure to update root directory in the Include/Config.php

$sRootPath = '';  // Must be an empty string if in the root path

Now access the website at the following URL:
30 March 2017, 00:57
Thanks Joe Shmoe
I moved to another computer and it looks like my initial problem has been resolved.
I created the database, and imported the sql file without a problem.
I then navigated to the install page and got the following notification,
Request-URI Too Long, with a 414 in the same popup just below the message.
Can anyone tell me is this something that I can fix in hiawatha, or is it a php related setting.

Thanks & Regards, john
Hugo Leisink
30 March 2017, 01:03
Use the MaxUrlLength setting to solve that issue.
30 March 2017, 03:46
Thanks Hugo, when I looked in the browser I seen a loop was taking place, this was because a re write was expected,
but all that was happening was, http://churchinfo.
as you can see from the above there is no url actually available to the browser as the web server did not re write it to point to the default page, which is in my case http://churchinfo., and so a loop developed, I solved this for now by just typing the full url and the page pops up, It would be nice to have a rewrite to stop this loop happening, which as of yet only happens if I type in the url without appending the page name.

Thanks, john
Hugo Leisink
30 March 2017, 08:42
First of all, this looks like a bug in churchinfo cms. You should report it.

I don't see any URL rewrite in a .htaccess in the source. What URL rewrite does it need?
This topic has been closed.