Wordpress install never completes

wordpress install timeout
5 February 2018, 17:15

I searched this forum prior to posting, sorry if this is a repeat issue.

I am testing Hiawatha with the most current version of wordpress. I have run into 2 issues at the very end of the install (wordpress seems to install fine, but am unsure of db integrity due to error messages). The first one I solved by adding salt manually to my wp-config.php, but the other I cannot figure out.

<ip-address>|Mon 05 Feb 2018 15:45:22 +0000|/usr/local/www/wordpress/wp-admin/install.php|CGI application timeout

In my virtualhost section I have added 'TimeForCGI = 120', but this did not resolve it.

Hiawatha v10.7
MariaDB v 10.2.11
PHP v 7.1.14
Wordpress v 4.9.2

jeremy ( I am the OP)
5 February 2018, 17:58
UPDATE: This may not be a Hiawatha problem after all. I get a similar, but not exactly the same, error when installing wp with nginx.

I ran a DB check after a reinstall with Hiawatha and all is in order.

The wp_users table is okay.

The wp_usermeta table is okay.

The wp_posts table is okay.

The wp_comments table is okay.

The wp_links table is okay.

The wp_options table is okay.

The wp_postmeta table is okay.

The wp_terms table is okay.

The wp_term_taxonomy table is okay.

The wp_term_relationships table is okay.

The wp_termmeta table is okay.

The wp_commentmeta table is okay.

Repairs complete. Please remove the following line from wp-config.php to prevent this page from being used by unauthorized users.

define('WP_ALLOW_REPAIR', true);
Hugo Leisink
5 February 2018, 23:38
I did a Wordpress (latest version) installation on Hiawatha. No issue here.
This topic has been closed.