Forum

PHP-FPM not working with Ubuntu14.04

Pierre
11 February 2018, 01:46
Hello all!
Currently I try to setup a "pipecode" with Hiawatha v10.7 but it's still not working. Simply output without editing.
Just as the content is in the php file.


Has someone a solution for it? :/
Hugo Leisink
12 February 2018, 22:17
What do you mean with 'pipecode'?
Pierre
13 February 2018, 20:26
Hey Hugo,
I've try to setup a open source software but right now I'm on the point that my php-fpm from php7 doesn't work. If I go to the info.php there is only a blank white page but the service is running...

Would send my configuration but it is "spam"
Nicolas
15 February 2018, 11:43
Hello,

Are you speaking about this "pipecode" : https://www.pipecode.org ?

It doesn't seem to need any special configuration, so your problem may be with setting up PHP or the FastCGIserver settings in hiawatha.conf. The default setting is :

FastCGIserver {
FastCGIid = PHP7
ConnectTo = /run/php/php7.0-fpm.sock
Extension = php
}


but the php socket may be in another place or have another name. You can find the correct name in the .conf file of you php pool. It should be in /etc/php/7.0/fpm/pool.d/ (if your using php 7.0). The default pool is www and it's .conf file is www.conf

After that, don't forget to set up your Virtual Host to use PHP :

UseFastCGI = PHP7


For your configuration, I think you can paste it in a message within the [code] bbcodes. Don't forget to blank your informations if you don't want people to know it.
Allowed BBcodes:
[quote]
[code]
[config]
[url]
[color]
[size]
[img]
[b]
[i]
[u]
[s]
[list]
[ul]
[ol]
[*]