Hiawatha.bat auto stops.

14 March 2018, 14:50

I just downloaded the lastest version of Hiawathat for WINDOWS 10 64bits. I followed the instructions of the INSTALL.txt file but when I try to execute :

C:\Program Files (x86)\Hiawatha>Hiawatha.bat

I get the following :
Press Ctrl-C to shutdown the Hiawatha webserver.
C:\Program Files (x86)\Hiawatha>

It instantly stops. I got the same problem as a Windows service...

I've tried to run the different lines of the bat file on their own and I got the same problem, it starts and stops suddendly.

I'm not sure what to do. I get no errors, empty log files, nothing ...

14 March 2018, 14:51
Sorry for the garbage message, but I got no option to preview the message before it's posted !

Hugo Leisink
14 March 2018, 15:00
Anything in the error logfile? Do you run it as Administrator? Binding to port 80 or 443 requires special privileges under Linux, so probably also under Windows.
14 March 2018, 15:28
In order :

- Nothing in the log files (error et the 4 others).
- Yes I ran CMD as an admin
- No process already running on port 80 - 443

Maybe I can try rebooting ...

Thanks for your answer
14 March 2018, 15:29
et = and. French btw.
14 March 2018, 15:53
Tried rebooting, same problem. I had Apache launched at start so It couldn't bind to port 80 but after I stopped the Apache service, I still had the same problem : it just stops on its own. Nothing in any log files.
Hugo Leisink
14 March 2018, 16:42
et = and. French btw.

:) C'est bon. Cette fin the semaine, moi et ma femme allons visiter Paris.

What if you run the binary program\hiawatha.exe? Any error message?
14 March 2018, 16:53
C'est une très belle ville ! (small mistake : "the" should be "de" ).

Yea, I get an error message from a file that doesn't exist (LINUX)
 /cygdrive/c/Program Files/Hiawatha/config: No such file or directory 

But when I checked the options for the command line of the bat file, I noticed that there was the option to tell the exe to start with another config file (mine located in config/hiawatha). So I don't know !
Hugo Leisink
14 March 2018, 17:14
That's what you get when trying to use multiple languages at the same time.

Anyway, what if you manually add those parameters? So, execute the following command:
program\hiawatha.exe -d -c config

Instead of just 'config', you might need to specify the full path to the config directory.
14 March 2018, 17:32
Haha, yea, but I'm not allowed to work on Linux yet. I wish I could have both like at home.

When I execute :
 hiawatha.exe -d -c config 

I get instant
Press Ctrl-C to shutdown the Hiawatha webserver.

I modified the line 10 in the conf file :
 set INSTALL_DIR = path\Hiawatha\ 
15 March 2018, 10:02
I even tried to put the directory in C:/ directly (to avoid spaces) and I tried

C:\Hiawatha\program>hiawatha.exe -d -c C:/Hiawatha/config  

But I get instant

Press Ctrl-C to shutdown the Hiawatha webserver.
Hugo Leisink
15 March 2018, 15:17
Just to be sure, when connecting to http://localhost/, there is no Hiawatha-welcome page. Right?

I'm thinking real hard, but I've no idea what goes wrong here. I have the feeling that the cause is not somewhere in Hiawatha, but something on your system. I have no idea what...
15 March 2018, 15:57
Yea, there is nothing, no programs emits on port 80 or 443 anyways so no, Hiawatha-welcome page doesn't show up.

Maybe, but I tried several other web servers and they're all working fine, strange.

Thanks for your help / time !
15 March 2018, 16:04
Edit : It works ! ! !

C:\Hiawatha\program>hiawatha.exe -d -c C:/Hiawatha/config 

It runs and doesn't stop on its own.

Between my 2 tests I had to upgrade my build for W10 to the latest one and now it's working fine.

Magic of IT.

Sorry to have waste your time and thanks !
Hugo Leisink
15 March 2018, 21:12
That's good news. I knew it had to be something else than Hiawatha. Happy webserving!
16 March 2018, 09:37
Thanks !

Passez un excellent week-end à Paris !
Allowed BBcodes: