Upload file size!!

6 June 2007, 17:39
I migrate from apache-1.3.3 to hiawatha-5.8. On my website I use CMS Typo3. I have some problem with file upload - when i try to upload files lager than 50 kb, i receive HTTP code 400 Bad Request. From php.ini "upload_max_filesize = 10M" "post_max_size = 11M". Suggestions...
Hugo Leisink
6 June 2007, 18:10
The default request size Hiawatha accepts is 64kb. If you want to increase this, use the MaxRequestSize option in httpd.conf. Example:
Port {
MaxRequestSize = 1024

makes Hiawatha accept HTTP requests up to 1MB. Be carefull with this setting. If you set it to high, an attacker can misuse it to DoS your server (make it run out of memory).

See the Hiawatha manualpage for more information about Hiawatha configuration options.
7 June 2007, 14:59
Problem solved
This topic has been closed.