Some questions

21 November 2009, 06:47

I am thinking about using your web server on my server as apache is eating my memory and i hate it.

Some questions i would like to ask are

1) is it easy to run php with hiawatha?

2) is there away to make ruby work with hiawatha?

3) how good does hiawatha utilise its Memory and CPU usage?

4) is there away to install svn with hiawatha?
21 November 2009, 07:32
Also can it be installed on centos 5.4?
21 November 2009, 12:17
Did not work i done what i said on the HowTo this is the copy of the command

[root@localhost ~]# cd /root/hiawatha-6.18
[root@localhost hiawatha-6.18]# ./configure --disable-ssl
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking crypt.h usability... yes
checking crypt.h presence... yes
checking for crypt.h... yes
checking rpcsvc/crypt.h usability... no
checking rpcsvc/crypt.h presence... no
checking for rpcsvc/crypt.h... no
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking netinet/tcp.h usability... yes
checking netinet/tcp.h presence... yes
checking for netinet/tcp.h... yes
checking for library containing gethostbyname... none required
checking for library containing socket... none required
checking for CommandChannel... no
checking for debug support... no
checking for caching... yes
checking for URL toolkit... yes
checking for IPv6 support... yes
checking for XSLT support... no
checking for clearenv... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for strcasestr... yes
checking for setenv... yes
checking for unsetenv... yes
checking for crypt... no
checking for crypt in -lcrypt... yes
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating etc/hiawatha/hiawatha.conf
config.status: creating doc/hiawatha.1
config.status: creating doc/php-fcgi.1
config.status: creating doc/cgi-wrapper.1
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
[root@localhost hiawatha-6.18]# make
make all-am
make[1]: Entering directory `/root/hiawatha-6.18'
make[1]: Leaving directory `/root/hiawatha-6.18'
[root@localhost hiawatha-6.18]# make install
make[1]: Entering directory `/root/hiawatha-6.18'
test -z "/usr/local/bin" || /bin/mkdir -p "/usr/local/bin"
/usr/bin/install -c 'ssi-cgi' '/usr/local/bin/ssi-cgi'
test -z "/usr/local/sbin" || /bin/mkdir -p "/usr/local/sbin"
/usr/bin/install -c 'cgi-wrapper' '/usr/local/sbin/cgi-wrapper'
/usr/bin/install -c 'hiawatha' '/usr/local/sbin/hiawatha'
/usr/bin/install -c 'php-fcgi' '/usr/local/sbin/php-fcgi'
/usr/bin/install -c 'wigwam' '/usr/local/sbin/wigwam'
test -z "/usr/local/sbin" || /bin/mkdir -p "/usr/local/sbin"
/usr/bin/install -c 'extra/newroot' '/usr/local/sbin/newroot'
make install-exec-hook
make[2]: Entering directory `/root/hiawatha-6.18'
chmod u+s /usr/local/sbin/cgi-wrapper
make[2]: Leaving directory `/root/hiawatha-6.18'
test -z "/usr/local/var/log/hiawatha" || /bin/mkdir -p "/usr/local/var/log/hiawatha"
test -z "/usr/local/share/man/man1" || /bin/mkdir -p "/usr/local/share/man/man1"
/usr/bin/install -c -m 644 './doc/cgi-wrapper.1' '/usr/local/share/man/man1/cgi-wrapper.1'
/usr/bin/install -c -m 644 './doc/hiawatha.1' '/usr/local/share/man/man1/hiawatha.1'
/usr/bin/install -c -m 644 './doc/newroot.1' '/usr/local/share/man/man1/newroot.1'
/usr/bin/install -c -m 644 './doc/php-fcgi.1' '/usr/local/share/man/man1/php-fcgi.1'
/usr/bin/install -c -m 644 './doc/ssi-cgi.1' '/usr/local/share/man/man1/ssi-cgi.1'
/usr/bin/install -c -m 644 './doc/wigwam.1' '/usr/local/share/man/man1/wigwam.1'
test -z "/usr/local/var/www/hiawatha" || /bin/mkdir -p "/usr/local/var/www/hiawatha"
/usr/bin/install -c -m 644 'doc/index.html' '/usr/local/var/www/hiawatha/index.html'
make install-data-hook
make[2]: Entering directory `/root/hiawatha-6.18'
make[2]: Leaving directory `/root/hiawatha-6.18'
make[1]: Leaving directory `/root/hiawatha-6.18'
[root@localhost hiawatha-6.18]#

I went to localhost and nothing and there is no folder in the /etc
Hugo Leisink
21 November 2009, 12:32
The answers to your questions:

1) I did my best. The online HOWTO should get you going.

2) Yes. Use this example [] to use Ruby with FastCGI.

3) Very good. It uses far less than Apache.

4) I don't know SVN, but my guess is that Hiawatha does not support SVN.

Can Hiawatha be installed on CentOS? Yes

By default, Hiawatha will be installed in /usr/local/ Try looking there.
21 November 2009, 12:44
Does not seem to be in /usr/local/

The command i ran to install it was

cd /root
wget the url of the server files
tar -xzf hiawatha-6.18.tar.gz
cd hiawatha-6.18
./configure --disable-ssl
make install

the out put of all that is in my other post
21 November 2009, 12:47
Found it in /usr/local/etc

Its a folder called hiawatha it has all the config stuff but how to i start the server?
Hugo Leisink
21 November 2009, 13:27
Run /usr/local/sbin/hiawatha
21 November 2009, 13:43
i get this message

warning: can't write PID file /usr/local/var/run/
21 November 2009, 13:49
also you should add some of this info on how to start and stop to the docs and where things are installed.
Hugo Leisink
21 November 2009, 15:40
Good point. Writing start/stop howto right now.

About the pid error. Did you start Hiawatha as root or as a normal user?
21 November 2009, 21:43
As root it started and worked but it does not show up in the top command.
Hugo Leisink
21 November 2009, 22:19
Is there any message about Hiawatha in the syslog?

Please, try the following installation.
make uninstall
./configure CFLAGS="-O2 -g -Wall" --bindir=/usr/bin --sbindir=/usr/sbin --mandir=/usr/share/man --sysconfdir=/etc --localstatedir=/var --disable-ssl
make install
21 November 2009, 22:30
Now i can not start it says the file /usr/local/sbin/hiawatha is not there.

also before i ran them commands i tryed to install php i uncommanded the the CGIHANDELER for the cgi:php but when i went to a php page i get the error 403
21 November 2009, 22:43
also there was nothing in the syslog that i can see.
22 November 2009, 00:33
i am going to give it ago on a deb install as i got a filling its todo with centos
22 November 2009, 02:21
okay installed it on deb using the make make install command it installed it in the same spot as centos and it does the same thing
Hugo Leisink
22 November 2009, 08:40
Read the HOWTO again, please. For Debian, use the following command:
apt-get install libc6-dev libssl-dev dpkg-dev debhelper fakeroot libxml2-dev libxslt1-dev
make deb
cd ..
dpkg -i hiawatha-<version>.deb

Don't mean to offend you, but how experienced are you with Linux / Unix?
22 November 2009, 10:07
i am a linux n00b and i am not offend. i also know how you fill as i am a php coder and when helping people it can get that why.
This topic has been closed.