puppy431 hiawatha

17 December 2009, 11:27

Hiawatha version:
Operating System: puppylinux431

hi all. i have been trying to setup hiawatha now for a few days and can't seem to access my site. i can get the site to load from local host and from my ubuntu pc via my wan ip. however i had my brother try and access the site my home ip and it is not working. i have set my router to use dmz. so like i said i can see the page from inside the network but not from outside. i also tried setting up the firewall to allow http port 80.

i know it has to be something really simple but i cant seem to figure it out. i also tried removing the binding port i read on puppy forum but to no avail. this is driving me nuts.:oops:

do i need to change the port from 80 to something else? i read some isp's block port 80?
Hugo Leisink
17 December 2009, 12:09
Make sure you have no Interface option set in your binding section. This makes Hiawatha bind to all interfaces.

According to this forum [], your ISP blocks port 80. So, try another port to check this.
17 December 2009, 19:10
ok i will try another port number

thnx Hugo
18 December 2009, 02:04
Ok got it working. I had to change the port number. I knew it was something too simple:D woot
This topic has been closed.