How do I install hiawatha for windows 7 x64?

12 October 2010, 21:39

Hiawatha version: 7.3
Operating System: Windows 7 Ultimate x64

So basically the problem is that I have no clue as to where to install hiawatha on x64. Because Program Files without x86 are x64. And it seems hiawatha is x86, right? So I would have to add (x86) to all the links. But will this work? Because I've just done that and it didn't work. It is still saying it can't find something.

I changed all the links in the .bat's, .ink's and .conf's. Are specific links in the binaries too?
So yea... I'm pretty clueless here.

P.S.: I have used hiawathe before way back at school. It worked great then but I heard my teacher he had a friend modify the hiawathe version so it would work on the school computers.
Hugo Leisink
12 October 2010, 22:12
I don't have access to a 64bit Windows 7 machine, so I can't test things for you. It is correct that the Windows version has hardcoded links to C:\Program Files and that it is compiled for 32bit operating systems. What you can do is install Cygwin [] and recompile Hiawatha for your 64bit OS.
make win

This of course requires some knowledge about compiling software. My guess is that you then can place Hiawatha (the created .exe files) in the Program Files directory.
13 October 2010, 13:31
I am currently studying IT at a uni in Holland. At least the international name is University of Rotterdam. However the real name is Hogeschool Rotterdam.

Anyway, that means I have some compiling experience. If cygwin isn't too complicated I can compile it. If it works I will post it here so that you can upload a windows 7 x64 link, if you want.

I'll let you know.
Hugo Leisink
13 October 2010, 13:33
If you know Linux or BSD, Cygwin should be very easy.

Hogeschool Rotterdam. Gezellig, dan zit je niet ver van mij vandaan
13 October 2010, 14:11
I managed to install cygwin on a school computer and am now trying to compile it for win xp to see how it all works.
When I got the folder and extract. Then go in that folder, and type ./configure in bash. It starts checking for things. Apparently some things it recognizes and something it doesn't.

It doesn't recognize:
whether make sets $(MAKE)... no
for gcc... no
for cc... no
for cl.exe... no
configure: error: no acceptable C compiler found in $PATH.

Do I have also install gcc, cc and cl.exe to make it work? And when I do, do I have to copy that compiler to the same folder hiawatha is in?
13 October 2010, 14:23
I just added almost everything gcc, cc and what I believe cl.exe to be. Now the configure report goes a lot furthur. Goes on forever and has a lot of yes. However sometimes it says no.

make is still not there. What do I else need?

I will upload a picture with the full report because now I am completely clueless.

P.S.: Sorry for the spam.

P.P.S.: Voor verdere referentie voor andere spreek ik nog engels. Waar zit jij dan?
Hugo Leisink
13 October 2010, 14:31
If you use Cygwin's setup.exe, click next, next, next until you see the Select Packages screen. Use 'make' in the search box. Make is the second last item in the Devel section. You probably want to remove the entire source directory en re-unzip it again. Probably something went wrong in your first compile attempt.

P.S.: No problem. That's what the forum is for.

P.P.S.: Woon en werk in Delft.
13 October 2010, 14:52
Hij lijkt nu te compileren omdat hij allerlei bestanden aanmaakt. Ik denk dat ik nu dus door heb hoe ik het moet doen. Thuis zal ik die windows 7 x64 binaries aanmaken.
13 October 2010, 17:50
Ok so when I tried at home it failed.

I'm getting bad programming errors. Like missing semicolons and random asterisks.
However I doubt they are because hiawatha is working fine for linux so it has to be windows side.

External image via
Hugo Leisink
13 October 2010, 18:21
You forgot to install the openssl-devel package.
13 October 2010, 19:06
I think we're getting close:

External image via

You know it's easier to say what I exactly need.
Hugo Leisink
13 October 2010, 20:05
Try installing the 'crypt' package. You can also use this package search page:
13 October 2010, 20:50
It is still giving me errors. A lot of them are about xslt and xml. Shall I install those too?
Hugo Leisink
13 October 2010, 20:52
You need the 'libxslt-devel' and the 'libxml2-devel' packages (both in the Devel section).
This topic has been closed.