Favicon displayed in http but not in https.

17 July 2008, 17:39
I got https to work by making a certificate exception just for debugging purposes, but then I noticed that when I am viewing the page using HTTP, the favicon is displayed normally next to the URL address bar, but when I view the same page using HTTPS, the favicon is not displayed. Is this normal for Hiawatha or am I missing some additional configuration settings?

Thank you.
Hugo Leisink
17 July 2008, 20:17
This is not a webserver issue, but a webbrowser issue. Try using an explicit favicon link tag in your HTML pages:

<link rel="shortcut icon" href="/favicon.ico">
17 July 2008, 23:12
You're right. That works. I like Hiawatha. Thank you. :-)
This topic has been closed.